blob: 345e7f5f3b4f881d6bddbb11fb056f3f97878be1 [file] [log] [blame]
uboot_prep_kimage() {
if test -e arch/${ARCH}/boot/compressed/vmlinux ; then
vmlinux_path="arch/${ARCH}/boot/compressed/vmlinux"
linux_suffix=""
linux_comp="none"
else
vmlinux_path="vmlinux"
linux_suffix=".gz"
linux_comp="gzip"
fi
${OBJCOPY} -O binary -R .note -R .comment -S "${vmlinux_path}" linux.bin
if [ "${linux_comp}" != "none" ] ; then
gzip -9 linux.bin
mv -f "linux.bin${linux_suffix}" linux.bin
fi
echo "${linux_comp}"
}