blob: 1579b05c6af75ebf30bd53b788dce06a6f6d5c4b [file] [log] [blame]
DEPENDS += "python-scons-native"
EXTRA_OESCONS ?= ""
do_configure[noexec] = "1"
scons_do_compile() {
${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} PREFIX=${prefix} prefix=${prefix} ${EXTRA_OESCONS} || \
die "scons build execution failed."
}
scons_do_install() {
${STAGING_BINDIR_NATIVE}/scons PREFIX=${D}${prefix} prefix=${D}${prefix} install ${EXTRA_OESCONS}|| \
die "scons install execution failed."
}
EXPORT_FUNCTIONS do_compile do_install