blob: 8a562dcb9967c436e0a96ee2409faf8874bd4466 [file] [log] [blame]
SUMMARY = "A sophisticated Numeric Processing Package for Python"
SECTION = "devel/python"
LICENSE = "PSF"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9f4e88b5748e8313caaf33d081ce65a3"
SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
file://remove-build-path-in-comments.patch \
file://add-glibc-check.patch \
${CONFIGFILESURI} "
CONFIGFILESURI ?= ""
CONFIGFILESURI_aarch64 = " \
file://config.h \
file://_numpyconfig.h \
"
CONFIGFILESURI_arm = " \
file://config.h \
file://numpyconfig.h \
"
CONFIGFILESURI_armeb = " \
file://config.h \
file://numpyconfig.h \
"
CONFIGFILESURI_mipsel = " \
file://config.h \
file://numpyconfig.h \
"
CONFIGFILESURI_x86 = " \
file://config.h \
file://numpyconfig.h \
"
CONFIGFILESURI_x86-64 = " \
file://config.h \
file://_numpyconfig.h \
"
CONFIGFILESURI_mips = " \
file://config.h \
file://_numpyconfig.h \
"
CONFIGFILESURI_powerpc = " \
file://config.h \
file://_numpyconfig.h \
"
CONFIGFILESURI_powerpc64 = " \
file://config.h \
file://_numpyconfig.h \
"
CONFIGFILESURI_mips64 = " \
file://config.h \
file://_numpyconfig.h \
"
CONFIGFILESURI_mips64n32 = " \
file://config.h \
file://_numpyconfig.h \
"
S = "${WORKDIR}/numpy-${PV}"
inherit distutils
# Make the build fail and replace *config.h with proper one
# This is a ugly, ugly hack - Koen
do_compile_prepend_class-target() {
BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
true
cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
}
FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
SRC_URI[md5sum] = "90bb9034652cefbada19cf7d141a6a61"
SRC_URI[sha256sum] = "f7f91842056a7cf680b0eaf8cefc5e46c69e2521e651128d2e6aaaccec8652ae"
# install what is needed for numpy.test()
RDEPENDS_${PN} = "python-unittest \
python-difflib \
python-pprint \
python-pickle \
python-shell \
python-nose \
python-doctest \
python-datetime \
python-distutils \
python-misc \
python-mmap \
python-netclient \
python-numbers \
python-pydoc \
python-pkgutil \
python-email \
python-subprocess \
python-compression \
python-ctypes \
python-threading \
"
RDEPENDS_${PN}_class-native = ""
BBCLASSEXTEND = "native nativesdk"