witherspoon-128: Initial commit

Create a machine/witherspoon-128.conf file to model a witherspoon
system with 128MB flash chips.

* New kernel device tree (witherspoon-128.dts).
* Bigger read-write filesystem. Remove the default from the
witherspoon layer (not needed as 6MB is the default) so that the
size value can be overwritten by the witherspoon-128.conf.

- To build this machine:
export MACHINE="witherspoon-128"; \
export BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE MACHINE"; \
bitbake obmc-phosphor-image

Witherspoon-128 is a system based on Witherspoon but with 128MB
flash chips. Create a device tree for this configuration.
Since this system is just a bringup vehicle, the device tree will
be carried as a patch instead of merging it in upstream linux.

(From meta-ibm rev: 903fd3532aaa967ddc7124095304f50cd4c9557c)

Change-Id: If02e8ad32fc2bff336d16c18513f2c238b28c28a
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/meta-witherspoon/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-ibm/meta-witherspoon/recipes-kernel/linux/linux-aspeed_%.bbappend
index 1b09937..e41a430 100644
--- a/meta-ibm/meta-witherspoon/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -1,2 +1,3 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 SRC_URI += "file://witherspoon.cfg"
+SRC_URI_append_witherspoon-128 = " file://0001-ARM-dts-Aspeed-Witherspoon-128-Update-BMC-partitioni.patch"