| SUMMARY = "Terminal multiplexer" |
| HOMEPAGE = "http://tmux.sourceforge.net" |
| SECTION = "console/utils" |
| |
| LICENSE = "ISC" |
| LIC_FILES_CHKSUM = "file://tmux.c;beginline=3;endline=17;md5=f256b76d52e7b4d02bf19144bdaca107" |
| |
| DEPENDS = "ncurses libevent" |
| |
| SRC_URI = "https://github.com/tmux/tmux/releases/download/${PV}/tmux-${PV}.tar.gz" |
| SRC_URI[md5sum] = "8eee5883b9f6550fa4efaad0c9ec38f3" |
| SRC_URI[sha256sum] = "e4fd347843bd0772c4f48d6dde625b0b109b7a380ff15db21e97c11a4dcdf93f" |
| |
| UPSTREAM_CHECK_URI = "https://github.com/tmux/tmux/releases" |
| |
| inherit autotools pkgconfig |
| |
| PACKAGECONFIG ??= "" |
| PACKAGECONFIG[utempter] = "ac_cv_header_utempter_h=yes,ac_cv_header_utempter_h=no,libutempter," |
| |
| do_configure:prepend() { |
| # The 'compat' directory is needed for output during the build but it's |
| # not automatically created when building outside the source directory. |
| mkdir -p ${B}/compat |
| } |