blob: febd836bbb6f5fc417c68b424c4cde21329f3d1f [file] [log] [blame]
SUMMARY = "Temp placeholder for skeleton function"
DESCRIPTION = "Temp placeholder for skeleton repository"
HOMEPAGE = "http://github.com/openbmc/skeleton"
PR = "r1"
inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
inherit obmc-phosphor-chassis-mgmt
inherit obmc-phosphor-fan-mgmt
inherit obmc-phosphor-flash-mgmt
inherit obmc-phosphor-policy-mgmt
inherit obmc-phosphor-sensor-mgmt
inherit obmc-phosphor-system-mgmt
inherit pythonnative
inherit python-dir
VIRTUAL-RUNTIME_skeleton_workbook ?= ""
DEPENDS += "glib-2.0 systemd python"
RDEPENDS_${PN} += "python-json python-subprocess python-compression libsystemd ${VIRTUAL-RUNTIME_skeleton_workbook}"
SRC_URI += "git://github.com/openbmc/skeleton"
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/*"
# RDEPEND on pflash if the openpower-pflash machine feature is set.
PACKAGECONFIG ??= "${@bb.utils.contains('MACHINE_FEATURES', 'openpower-pflash', 'openpower-pflash', '', d)}"
PACKAGECONFIG[openpower-pflash] = ",,,pflash"
SRCREV = "b0d0a745b43df991241bb86227248147539f2129"
S = "${WORKDIR}"
# needed to invoke setuptools
export STAGING_INCDIR
export STAGING_LIBDIR
export BUILD_SYS
export HOST_SYS
export PYTHON_SITEPACKAGES_DIR
do_compile() {
oe_runmake -C git PYTHON=${PYTHON}
}
do_install() {
oe_runmake -C git install \
PYTHON=${PYTHON} \
DESTDIR=${D} \
PREFIX=/usr
}