| SUMMARY = "Extremely Fast Compression algorithm" |
| DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems." |
| |
| LICENSE = "BSD | BSD-2-Clause | GPL-2.0" |
| LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=ebc2ea4814a64de7708f1571904b32cc \ |
| file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| file://LICENSE;md5=d57c0d21cb917fb4e0af2454aa48b956 \ |
| " |
| |
| PE = "1" |
| |
| SRCREV = "b3692db46d2b23a7c0af2d5e69988c94f126e10a" |
| |
| SRC_URI = "git://github.com/lz4/lz4.git \ |
| file://run-ptest \ |
| " |
| UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)" |
| |
| S = "${WORKDIR}/git" |
| |
| EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}" |
| |
| do_install() { |
| oe_runmake install |
| } |
| |
| BBCLASSEXTEND = "native nativesdk" |