blob: d638dc1c3caf8f00635c8033a50df580a101506f [file] [log] [blame]
DESCRIPTION = "Notary is a Docker project that allows anyone to have trust over arbitrary collections of data"
HOMEPAGE = "https://github.com/docker/notary"
SECTION = "devel/go"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=771ddb425ba03c8fab49e5bd9854a4a2"
SRCNAME = "notary"
PKG_NAME = "github.com/docker/${SRCNAME}"
SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}"
SRCREV = "c8aa8cf53cbcda2e92def0c9291e25d770493494"
PV = "0.4.2+git${SRCPV}"
S = "${WORKDIR}/git"
# NO-OP the do compile rule because this recipe is source only.
do_compile() {
}
do_install() {
install -d ${D}${prefix}/local/go/src/${PKG_NAME}
for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do
if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then
mkdir -p ${D}${prefix}/local/go/$(dirname $j)
fi
cp $j ${D}${prefix}/local/go/$j
done
cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/
}
SYSROOT_PREPROCESS_FUNCS += "go_notary_sysroot_preprocess"
go_notary_sysroot_preprocess () {
install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME}
cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
}
FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"