blob: 5c095ac2893269af1665d796f283acca13568df8 [file] [log] [blame]
DESCRIPTION = "SeaBIOS"
HOMEPAGE = "http://www.coreboot.org/SeaBIOS"
LICENSE = "LGPLv3"
SECTION = "firmware"
SRC_URI = " \
http://code.coreboot.org/p/seabios/downloads/get/${PN}-${PV}.tar.gz \
file://hostcc.patch \
"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6 \
"
SRC_URI[md5sum] = "e21b6f3e54d492be837ef20d66617f81"
SRC_URI[sha256sum] = "8a2a562fe5cfd37fe8327cdc4a60accdfe441e235b29e6999fdeb442ba98d608"
FILES_${PN} = "/usr/share/firmware"
DEPENDS = "util-linux-native file-native bison-native flex-native gettext-native iasl-native python-native"
TUNE_CCARGS = ""
EXTRA_OEMAKE += "HOSTCC='${BUILD_CC}'"
EXTRA_OEMAKE += "CROSS_PREFIX=${TARGET_PREFIX}"
COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
do_configure() {
oe_runmake defconfig
}
do_compile() {
unset CPP
unset CPPFLAGS
oe_runmake
}
do_install() {
oe_runmake
install -d ${D}/usr/share/firmware
install -m 0644 out/bios.bin ${D}/usr/share/firmware/
}