blob: b6cd2ac9b9e60e5c97f257bc3f6701b536bc8bde [file] [log] [blame]
SUMMARY = "System call tracing tool"
HOMEPAGE = "http://strace.sourceforge.net"
SECTION = "console/utils"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=488acb3aaaf5d14a2e1a852d13668a70"
SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
file://disable-git-version-gen.patch \
file://more-robust-test-for-m32-mx32-compile-support.patch \
file://update-gawk-paths.patch \
file://Makefile-ptest.patch \
file://run-ptest \
file://0001-Fix-build-when-using-non-glibc-libc-implementation-o.patch \
file://mips-SIGEMT.patch \
file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \
"
SRC_URI[md5sum] = "2873366cac98770efcbed6e748d5ef23"
SRC_URI[sha256sum] = "98487cb5178ec1259986cc9f6e2a844f50e5d1208c112cc22431a1e4d9adf0ef"
inherit autotools ptest bluetooth
RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
PACKAGECONFIG_class-target ??= "\
${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
"
PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
TESTDIR = "tests"
do_install_append() {
# We don't ship strace-graph here because it needs perl
rm ${D}${bindir}/strace-graph
}
do_compile_ptest() {
oe_runmake -C ${TESTDIR} buildtest-TESTS
}
do_install_ptest() {
oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
}
BBCLASSEXTEND = "native"
TOOLCHAIN = "gcc"