blob: 2689e8fac2388b820985ac2f7e4749d1e04f4e3b [file] [log] [blame]
require ${BPN}.inc
SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/mesa-${PV}.tar.xz \
file://replace_glibc_check_with_linux.patch \
file://disable-asm-on-non-gcc.patch \
file://0001-Use-wayland-scanner-in-the-path.patch \
"
SRC_URI[md5sum] = "8f808e92b893d412fbd6510e1d16f5c5"
SRC_URI[sha256sum] = "f8f191f909e01e65de38d5bdea5fb057f21649a3aed20948be02348e77a689d4"
#because we cannot rely on the fact that all apps will use pkgconfig,
#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
do_install_append() {
if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
fi
}