blob: 2071c1fbd83bd2f2dff1d30f5070078991dd14fd [file] [log] [blame]
SUMMARY = "Jpeg 2000 implementation"
HOMEPAGE = "https://jasper-software.github.io/jasper/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a80440d1d8f17d041c71c7271d6e06eb"
SRC_URI = "git://github.com/jasper-software/jasper.git;protocol=https"
SRCREV = "9a2835a81ce9c41a48f36dadce79f110da8d6c75"
S = "${WORKDIR}/git"
inherit cmake
PACKAGECONFIG ??= ""
PACKAGECONFIG[jpeg] = "-DJAS_ENABLE_LIBJPEG=true, -DJAS_ENABLE_LIBJPEG=false, jpeg"
PACKAGECONFIG[opengl] = "-DJAS_ENABLE_OPENGL=true, -DJAS_ENABLE_OPENGL=false, freeglut"
EXTRA_OECMAKE_append = " -DJAS_ENABLE_SHARED=true"
do_install_append() {
chrpath -d ${D}${bindir}/jasper
chrpath -d ${D}${bindir}/imginfo
chrpath -d ${D}${bindir}/imgcmp
chrpath -d ${D}${libdir}/libjasper.so.*
}