| SUMMARY = "Linux man-pages" |
| DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs" |
| SECTION = "console/utils" |
| HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages" |
| LICENSE = "GPL-2.0-or-later & GPL-2.0-only & GPL-1.0-or-later & BSD-2-Clause & BSD-3-Clause & BSD-4-Clause & MIT" |
| |
| LIC_FILES_CHKSUM = "file://README;md5=cbd51cd3dd298230df8ddd4637e65c37 \ |
| file://LICENSES/BSD-2-Clause.txt;md5=d0f280d1058e77e66264a9b9e10e6c89 \ |
| file://LICENSES/BSD-3-Clause.txt;md5=71f739ef75581cae312e8c711bcdab16 \ |
| file://LICENSES/BSD-4-Clause-UC.txt;md5=1da3cf8ad50cd8d5d1de3cfc53196d01 \ |
| file://LICENSES/GPL-1.0-or-later.txt;md5=e5b7c80002ef72ab868b43ce47b65125 \ |
| file://LICENSES/GPL-2.0-only.txt;md5=3d26203303a722dedc6bf909d95ba815 \ |
| file://LICENSES/GPL-2.0-or-later.txt;md5=3d26203303a722dedc6bf909d95ba815 \ |
| file://LICENSES/Linux-man-pages-copyleft.txt;md5=173b960c686ff2d26f043ddaeb63f6ce \ |
| file://LICENSES/MIT.txt;md5=7dda4e90ded66ab88b86f76169f28663 \ |
| " |
| SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/${BP}.tar.gz" |
| |
| SRC_URI[sha256sum] = "b2dd44ca0342b50923291f06bdba38c42438e10c04843ce1f731cf3f50631e0a" |
| |
| inherit manpages |
| |
| MAN_PKG = "${PN}" |
| |
| PACKAGECONFIG ??= "" |
| PACKAGECONFIG[manpages] = "" |
| |
| do_configure[noexec] = "1" |
| do_compile[noexec] = "1" |
| |
| do_install() { |
| oe_runmake install prefix=${prefix} DESTDIR=${D} |
| rm -rf ${D}${mandir}/man3/crypt.3 |
| rm -rf ${D}${mandir}/man3/crypt_r.3 |
| rm -rf ${D}${mandir}/man3/getspnam.3 |
| rm -rf ${D}${mandir}/man5/passwd.5 |
| } |
| |
| # Only deliveres man-pages so FILES:${PN} gets everything |
| FILES:${PN}-doc = "" |
| FILES:${PN} = "${mandir}/*" |