blob: c5c8d42e2d0160b37c27fd94f06e15a11cf50484 [file] [log] [blame]
DESCRIPTION = "DNS toolkit for Python"
HOMEPAGE = "http://www.dnspython.org/"
LICENSE = "ISC"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5af50906b5929837f667dfe31052bd34"
SRC_URI[sha256sum] = "a0034815a59ba9ae888946be7ccca8f7c157b286f8455b379c692efb51022a15"
inherit pypi python_hatchling ptest
SRC_URI += " \
file://run-ptest \
"
RDEPENDS:${PN}-ptest += " \
python3-pytest \
python3-unittest-automake-output \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}
DEPENDS += "\
python3-wheel-native \
python3-setuptools-scm-native \
"
RDEPENDS:${PN} += " \
python3-crypt \
python3-io \
python3-math \
python3-netclient \
python3-numbers \
python3-threading \
"