blob: 610a966d40622840a51d2a81021864cabcc82632 [file] [log] [blame]
SUMMARY = "Parse strings using a specification based on the Python format() syntax"
HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=8ab458ad281b60e6f1b39b3feafbfc05"
SRC_URI[sha256sum] = "09002ca350ad42e76629995f71f7b518670bcf93548bdde3684fd55d2be51975"
SRC_URI += " \
file://run-ptest \
"
inherit pypi python_setuptools_build_meta ptest
RDEPENDS:${PN} += "\
python3-datetime \
python3-logging \
python3-numbers \
"
RDEPENDS:${PN}-ptest += " \
python3-pytest \
"
do_install_ptest() {
cp -f ${S}/tests/test*.py ${D}${PTEST_PATH}/
}