blob: bc94e29ea3798591731c62eb73b2bfe1c346f544 [file] [log] [blame]
require wireguard.inc
SRCREV = "d553aa7c52ac78c1963886afb74ba861b0b7b0fc"
SRC_URI = "git://git.zx2c4.com/wireguard-linux-compat"
inherit module kernel-module-split
DEPENDS = "virtual/kernel libmnl"
# This module requires Linux 3.10 higher and several networking related
# configuration options. For exact kernel requirements visit:
# https://www.wireguard.io/install/#kernel-requirements
EXTRA_OEMAKE_append = " \
KERNELDIR=${STAGING_KERNEL_DIR} \
"
MAKE_TARGETS = "module"
RRECOMMENDS_${PN} = "kernel-module-xt-hashlimit"
MODULE_NAME = "wireguard"
# Kernel module packages MUST begin with 'kernel-module-', otherwise
# multilib image generation can fail.
#
# The following line is only necessary if the recipe name does not begin
# with kernel-module-.
PKG_${PN} = "kernel-module-${MODULE_NAME}"
module_do_install() {
install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
install -m 0644 ${MODULE_NAME}.ko \
${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
}