blob: fb9ba310041ce945aafb5515dbfb6db80573bd09 [file] [log] [blame]
SUMMARY = "BIOS BMC SMM Error Logger"
DESCRIPTION = "Allows BIOS in SMM to log errors to the BMC"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
DEPENDS += " \
boost \
fmt \
stdplus \
systemd \
nlohmann-json \
libbej \
sdbusplus \
phosphor-dbus-interfaces \
"
SRCREV = "a307287922ab1a59d8f71c1ca9a35ad4a100c054"
PV = "0.1+git${SRCPV}"
PR = "r1"
SRC_URI = "git://github.com/openbmc/bios-bmc-smm-error-logger;branch=main;protocol=https"
S = "${WORKDIR}/git"
SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.bios_bmc_smm_error_logger.service"
inherit meson pkgconfig systemd
EXTRA_OEMESON = " \
-Dtests=disabled \
"