blob: 4b612e1d14279bb560e1699b790277594ba2bbaa [file] [log] [blame]
SUMMARY = "Phosphor DBus Interfaces"
DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML"
PR = "r1"
PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit autotools pkgconfig
inherit pythonnative
inherit phosphor-dbus-yaml
DEPENDS += "autoconf-archive-native"
DEPENDS += "sdbus++-native"
SRC_URI += "git://github.com/openbmc/phosphor-dbus-interfaces"
SRCREV = "a1acf5c6397356ae0f45ba5b9d78638c00b62f3d"
DEPENDS_remove_class-native = "sdbus++-native"
DEPENDS_remove_class-nativesdk = "sdbus++-native"
PACKAGECONFIG ??= "libphosphor_dbus"
PACKAGECONFIG[libphosphor_dbus] = " \
--enable-libphosphor_dbus, \
--disable-libphosphor_dbus, \
systemd sdbusplus, \
libsystemd sdbusplus \
"
PACKAGECONFIG_remove_class-native = "libphosphor_dbus"
PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus"
BBCLASSEXTEND += "native nativesdk"