blob: 734aca11c140d0b1dcb32ba3cba5fac2a070eaf9 [file] [log] [blame]
SUMMARY = "To merge the Host and BMC config files generated from MRW "
DESCRIPTION = "Merge host provided FRU info config file, fru info config, \
which is not sent by host config, and BMC accessible FRU info config \
files generated by gen-ipmi-fru.pl into a single config file. \
fru-gen parser parses the merged config file and generates cpp file"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
inherit phosphor-ipmi-host
DEPENDS += "virtual/phosphor-ipmi-fru-read-inventory"
DEPENDS += "virtual/phosphor-ipmi-fru-read-bmc-inventory"
DEPENDS += "virtual/phosphor-ipmi-fru-read-not-sent-by-host-inventory"
PROVIDES += "virtual/phosphor-ipmi-fru-merge-config"
do_install_append() {
SRC=${config_datadir}
DEST=${D}${config_datadir}
install -d ${DEST}
cat ${SRC}/config.yaml ${SRC}/bmc-fru-config.yaml > ${DEST}/fru_config.yaml
cat ${SRC}/fru-config-not-sent-by-host.yaml >> ${DEST}/fru_config.yaml
}