blob: be53df536fa2f01b9139b35ef8b084a19a56a898 [file] [log] [blame]
SUMMARY = "Generated callout information for phosphor-logging"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
inherit phosphor-logging
inherit mrw-xml
DEPENDS += " \
mrw-native \
mrw-perl-tools-native \
"
PROVIDES += "virtual/phosphor-logging-callouts"
S = "${WORKDIR}"
do_install() {
DEST=${D}${callouts_datadir}
install -d ${DEST}
${bindir}/perl-native/perl \
${bindir}/gen_callouts.pl \
-m ${mrw_datadir}/${MRW_XML} \
-o ${DEST}/callouts.yaml
}