blob: 75a1d842954fa2dac1bc5c579be5d8f0d9f404ff [file] [log] [blame]
SUMMARY = "OpenBMC console daemon"
DESCRIPTION = "Daemon to handle UART console connections"
HOMEPAGE = "http://github.com/openbmc/obmc-console"
PR = "r1"
inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
inherit autotools
TARGET_CFLAGS += "-fpic -O2"
SRC_URI += "git://github.com/openbmc/obmc-console"
SRC_URI += "file://${PN}.conf"
SRCREV = "2eacda524e98c7964e542e01aabf82360cf60344"
do_install_append() {
install -m 0755 -d ${D}${sysconfdir}
install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
}
S = "${WORKDIR}/git"