blob: a4dcfab3d5a06787533f20a84b010284403ee51a [file] [log] [blame]
SUMMARY = "Phosphor OpenBMC WriteFRU for OpenPOWER systems"
DESCRIPTION = "Phosphor OpenBMC WriteFRU for OpenPOWER based systems"
HOMEPAGE = "https://github.com/openbmc/ipmi-fru-parser"
PR = "r1"
RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw"
inherit obmc-phosphor-license
DEPENDS += "systemd \
host-ipmid \
"
RDEPENDS_${PN} += "libsystemd"
TARGET_CFLAGS += "-std=gnu++14"
SRC_URI += "git://github.com/openbmc/ipmi-fru-parser"
SRCREV = "675272789d4dba9a8c308f3cb1f7deb8b5b2ec41"
FILES_${PN} += "${libdir}/host-ipmid/*.so"
FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug"
S = "${WORKDIR}/git"
do_install() {
install -m 0755 -d ${D}${libdir}/host-ipmid
install -m 0755 ${S}/*.so ${D}${libdir}/host-ipmid/
}