blob: 0a24ca9ebc9d8b9090bf327d2a992751878b69d9 [file] [log] [blame]
SUMMARY = "A library implementing the 'SemVer' scheme."
DESCRIPTION = "Semantic version comparison for Python (see http://semver.org/)"
HOMEPAGE = "https://github.com/rbarrois/python-semanticversion"
LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4fb31e3c1c7eeb8b5e8c07657cdd54e2"
SRC_URI[sha256sum] = "bdabb6d336998cbb378d4b9db3a4b56a1e3235701dc05ea2690d9a997ed5041c"
PYPI_PACKAGE = "semantic_version"
inherit pypi setuptools3
RDEPENDS:${PN} += " \
${PYTHON_PN}-pkg-resources \
"
BBCLASSEXTEND = "native nativesdk"
UPSTREAM_CHECK_REGEX = "/semantic-version/(?P<pver>(\d+[\.\-_]*)+)/"