blob: 82833bc6a3359c1fd51eed3bc46598fe93317a8f [file] [log] [blame]
SUMMARY = "Chassis Power Control service for Intel based platforms"
DESCRIPTION = "Chassis Power Control service for Intel based platforms"
SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=ssh"
SRCREV = "d6c5ad1008e63c16566a266f89aa8feec664050f"
PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
inherit cmake systemd
SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Chassis.Control.Power.service \
chassis-system-reset.service \
chassis-system-reset.target"
DEPENDS += " \
boost \
i2c-tools \
libgpiod \
sdbusplus \
phosphor-logging \
"