| SUMMARY = "Simple Python wrapper around the OpenSSL library" |
| HOMEPAGE = "https://pyopenssl.org/" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| |
| DEPENDS += "openssl python3-cryptography" |
| |
| SRC_URI[sha256sum] = "6aa33039a93fffa4563e655b61d11364d01264be8ccb49906101e02a334530bf" |
| |
| PYPI_PACKAGE = "pyOpenSSL" |
| inherit pypi setuptools3 |
| |
| PACKAGES =+ "${PN}-tests" |
| FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test" |
| |
| RDEPENDS:${PN}:class-target = " \ |
| python3-cryptography \ |
| python3-six \ |
| python3-threading \ |
| " |
| RDEPENDS:${PN}-tests = "${PN}" |
| |
| BBCLASSEXTEND = "native nativesdk" |