| SUMMARY = "Small and fast POSIX-compliant shell" |
| HOMEPAGE = "http://gondor.apana.org.au/~herbert/dash/" |
| SECTION = "System Environment/Shells" |
| |
| LICENSE = "BSD & GPLv2+" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=b5262b4a1a1bff72b48e935531976d2e" |
| |
| inherit autotools update-alternatives |
| |
| SRC_URI = "http://gondor.apana.org.au/~herbert/${BPN}/files/${BP}.tar.gz \ |
| file://0001-Fix-printf-format-errors-with-clang.patch \ |
| " |
| SRC_URI[md5sum] = "8f485f126c05d0ab800e85abfe1987aa" |
| SRC_URI[sha256sum] = "3c663919dc5c66ec991da14c7cf7e0be8ad00f3db73986a987c118862b5f6071" |
| |
| EXTRA_OECONF += "--bindir=${base_bindir}" |
| |
| ALTERNATIVE_${PN} = "sh" |
| ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh" |
| ALTERNATIVE_TARGET[sh] = "${base_bindir}/dash" |
| ALTERNATIVE_PRIORITY = "10" |
| |
| pkg_postinst_${PN} () { |
| grep -q "^${base_bindir}/dash$" $D${sysconfdir}/shells || echo ${base_bindir}/dash >> $D${sysconfdir}/shells |
| } |
| |
| pkg_postrm_${PN} () { |
| printf "$(grep -v "^${base_bindir}/dash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells |
| } |