| SUMMARY = "Terminal multiplexer" |
| HOMEPAGE = "http://tmux.sourceforge.net" |
| SECTION = "console/utils" |
| |
| LICENSE = "ISC" |
| LIC_FILES_CHKSUM = "file://tmux.c;beginline=3;endline=17;md5=f256b76d52e7b4d02bf19144bdaca107" |
| |
| DEPENDS = "ncurses libevent" |
| |
| SRC_URI = "https://github.com/tmux/tmux/releases/download/${PV}/tmux-${PV}.tar.gz" |
| SRC_URI[md5sum] = "d541ff392249f94c4f3635793556f827" |
| SRC_URI[sha256sum] = "b17cd170a94d7b58c0698752e1f4f263ab6dc47425230df7e53a6435cc7cd7e8" |
| |
| UPSTREAM_CHECK_URI = "https://github.com/tmux/tmux/releases" |
| |
| inherit autotools pkgconfig |
| |
| PACKAGECONFIG ??= "" |
| PACKAGECONFIG[utempter] = "ac_cv_header_utempter_h=yes,ac_cv_header_utempter_h=no,libutempter," |
| |
| do_configure_prepend() { |
| # The 'compat' directory is needed for output during the build but it's |
| # not automatically created when building outside the source directory. |
| mkdir ${B}/compat |
| } |