| SUMMARY = "User space daemon for extended IEEE 802.11 management" |
| HOMEPAGE = "http://w1.fi/hostapd/" |
| SECTION = "kernel/userland" |
| LICENSE = "BSD-3-Clause" |
| LIC_FILES_CHKSUM = "file://hostapd/README;md5=c905478466c90f1cefc0df987c40e172" |
| |
| DEPENDS = "libnl openssl" |
| |
| SRC_URI = " \ |
| http://w1.fi/releases/hostapd-${PV}.tar.gz \ |
| file://defconfig \ |
| file://init \ |
| file://hostapd.service \ |
| " |
| |
| |
| SRC_URI[sha256sum] = "206e7c799b678572c2e3d12030238784bc4a9f82323b0156b4c9466f1498915d" |
| |
| S = "${WORKDIR}/hostapd-${PV}" |
| B = "${WORKDIR}/hostapd-${PV}/hostapd" |
| |
| inherit update-rc.d systemd pkgconfig features_check |
| |
| CONFLICT_DISTRO_FEATURES = "openssl-no-weak-ciphers" |
| |
| INITSCRIPT_NAME = "hostapd" |
| |
| SYSTEMD_SERVICE:${PN} = "hostapd.service" |
| SYSTEMD_AUTO_ENABLE:${PN} = "disable" |
| |
| do_configure:append() { |
| install -m 0644 ${WORKDIR}/defconfig ${B}/.config |
| } |
| |
| do_compile() { |
| export CFLAGS="-MMD -O2 -Wall -g" |
| export EXTRA_CFLAGS="${CFLAGS}" |
| make V=1 |
| } |
| |
| do_install() { |
| install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/ |
| install -m 0644 ${B}/hostapd.conf ${D}${sysconfdir} |
| install -m 0755 ${B}/hostapd ${D}${sbindir} |
| install -m 0755 ${B}/hostapd_cli ${D}${sbindir} |
| install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd |
| install -m 0644 ${WORKDIR}/hostapd.service ${D}${systemd_unitdir}/system/ |
| sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service |
| } |
| |
| CONFFILES:${PN} += "${sysconfdir}/hostapd.conf" |