| require mesa.inc |
| |
| SUMMARY += " (OpenGL only, no EGL/GLES)" |
| |
| PROVIDES = "virtual/libgl virtual/mesa" |
| |
| S = "${WORKDIR}/mesa-${PV}" |
| |
| # At least one DRI rendering engine is required to build mesa. |
| # When no X11 is available, use osmesa for the rendering engine. |
| PACKAGECONFIG ??= "opengl dri ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'osmesa gallium', d)}" |
| PACKAGECONFIG:class-target = "opengl dri ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'osmesa gallium', d)}" |
| |
| # 21.0.0 version fails to build when any driver is enabled in DRIDRIVERS |
| # ./mesa-21.0.0/meson.build:519:4: ERROR: Problem encountered: building dri drivers require at least one windowing system |
| DRIDRIVERS ?= "" |