blob: 8af13b6f2b5091ef6492e870e343ecda19a2038a [file] [log] [blame]
SUMMARY = "Python project template generator with batteries included"
DESCRIPTION = "PyScaffold package helps to setup a new Python project. \
After installation, it provides a new command [putup], which could be \
used to create template Projects."
HOMEPAGE = "https://github.com/pyscaffold/pyscaffold"
SECTION = "devel/python"
LICENSE = "0BSD & MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=14a49c74a1d91829908ac756c07e6b91"
DEPENDS += "python3-setuptools-scm-native"
SRC_URI[sha256sum] = "4dbdb76c45ad860dfe64e00103c18a6279ce382ddd5a7f18651c129c5539a0ab"
inherit pypi python_setuptools_build_meta
PYPI_PACKAGE = "PyScaffold"
RDEPENDS:${PN} += " \
python3-email \
python3-compression \
"
BBCLASSEXTEND = "native nativesdk"