blob: b745f349e754fe978246ab5fde7f2043ec642558 [file] [log] [blame]
SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
HOMEPAGE = "https://pypi.org/project/ruamel.yaml/"
AUTHOR = "Anthon van der Neut"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=0e5f41db57c3a8d3584b450d35985ad1"
PYPI_PACKAGE = "ruamel.yaml"
inherit pypi setuptools3
SRC_URI[sha256sum] = "ec939063761914e14542972a5cba6d33c23b0859ab6342f61cf070cfc600efc2"
RDEPENDS:${PN} += "\
${PYTHON_PN}-shell \
${PYTHON_PN}-datetime \
${PYTHON_PN}-netclient \
"
do_install:prepend() {
export RUAMEL_NO_PIP_INSTALL_CHECK=1
}
BBCLASSEXTEND = "native nativesdk"