| SUMMARY = "Display or change ethernet card settings" |
| DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces." |
| HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/" |
| SECTION = "console/network" |
| LICENSE = "GPLv2+" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216" |
| |
| SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \ |
| file://run-ptest \ |
| file://avoid_parallel_tests.patch \ |
| " |
| |
| SRC_URI[md5sum] = "0a1c78787c7dcf077016ed86372a472f" |
| SRC_URI[sha256sum] = "e200516727cc9583e8b63fd6e72f667f9ed41bb4f0577ff4803b60c64cfd1dbc" |
| |
| inherit autotools ptest |
| RDEPENDS_${PN}-ptest += "make" |
| |
| do_compile_ptest() { |
| oe_runmake buildtest-TESTS |
| } |
| |
| do_install_ptest () { |
| cp ${B}/Makefile ${D}${PTEST_PATH} |
| install ${B}/test-cmdline ${D}${PTEST_PATH} |
| install ${B}/test-features ${D}${PTEST_PATH} |
| install ${B}/ethtool ${D}${PTEST_PATH}/ethtool |
| sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile |
| } |