blob: 171c126a2c7bfbeef500c9fd0f53edf0a904d6f3 [file] [log] [blame]
SUMMARY = "Phosphor OpenBMC WriteFRU for OpenPOWER systems"
DESCRIPTION = "Phosphor OpenBMC WriteFRU for OpenPOWER based systems"
HOMEPAGE = "https://github.com/openbmc/ipmi-fru-parser"
PR = "r1"
RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw"
inherit obmc-phosphor-license
DEPENDS += " \
systemd \
host-ipmid \
"
RDEPENDS_${PN} += "libsystemd"
TARGET_CFLAGS += " -fpic -std=gnu++14"
SRC_URI += "git://github.com/openbmc/ipmi-fru-parser"
SRCREV = "3365ec8a073443e09d12c0c701b33c0c844f6362"
FILES_SOLIBSDEV += "${libdir}/host-ipmid/lib*${SOLIBSDEV}"
FILES_${PN} += "${libdir}/host-ipmid/lib*${SOLIBS}"
FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug/lib*${SOLIBS}"
S = "${WORKDIR}/git"
do_install() {
oe_runmake install DESTDIR=${D} LIBDIR=${libdir} BINDIR=${sbindir}
}