blob: 7bd2d9d7475ec7313d1a676150f6f1202182da68 [file] [log] [blame]
# Common code for Phosphor OpenBMC systemd services.
inherit systemd
SYSTEMD_SERVICE_${PN} = "${PN}.service"
SRC_URI += " \
file://${PN}.service \
"
do_install_append() {
# install systemd unit files
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system
}