blob: eda2b95eec164fb4991c2fb1255a9b08a4a6da27 [file] [log] [blame]
SUMMARY = "C++ bindings for systemd dbus APIs"
DESCRIPTION = "C++ bindings for systemd dbus APIs."
HOMEPAGE = "http://github.com/openbmc/sdbusplus"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit autotools pkgconfig
inherit obmc-phosphor-python-autotools
DEPENDS += "autoconf-archive-native"
RDEPENDS_${PN} += " \
python-inflection \
python-mako \
python-pyyaml \
"
SRC_URI += "git://github.com/openbmc/sdbusplus"
SRCREV = "aa2e7f7170327511110a448c1314a1ef2195ee25"
PACKAGECONFIG ??= "libsdbusplus"
PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
S = "${WORKDIR}/git"
PROVIDES_prepend = "sdbus++ "
PACKAGES_prepend = "sdbus++ "
FILES_sdbus++_append = " ${bindir}/sdbus++"
PYTHON_AUTOTOOLS_PACKAGE = "sdbus++"
PACKAGECONFIG_remove_class-native = "libsdbusplus"
PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
ALLOW_EMPTY_${PN} = "1"
BBCLASSEXTEND += "native nativesdk"