blob: 14b34a2808a09b1c290b561664f49d18f9189815 [file] [log] [blame]
SUMMARY = "Python bindings for GStreamer 1.0"
HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
SECTION = "multimedia"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
SRC_URI[md5sum] = "326f4f4c23e2477bf3d5839c465a42ca"
SRC_URI[sha256sum] = "36a00a256c25ccaaa9b965a6f09d6158dfb77558145ab6b25809938732c7161f"
DEPENDS = "gstreamer1.0 python3-pygobject"
RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject"
PNREAL = "gst-python"
S = "${WORKDIR}/${PNREAL}-${PV}"
# gobject-introspection is mandatory and cannot be configured
REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
inherit meson pkgconfig distutils3-base upstream-version-is-even gobject-introspection features_check
do_install_append() {
# Note that this particular find line is taken from the Debian packaging for
# gst-python1.0.
find "${D}" \
-name '*.pyc' -o \
-name '*.pyo' -o \
-name '*.la' -o \
-name 'libgstpythonplugin*' \
-delete
}