| DESCRIPTION = "Google gRPC" |
| HOMEPAGE = "http://www.grpc.io/" |
| SECTION = "devel/python" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| |
| DEPENDS += "${PYTHON_PN}-protobuf" |
| |
| SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch" |
| SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \ |
| file://boring_ssl.patch \ |
| file://mips_bigendian.patch \ |
| file://0001-absl-always-use-asm-sgidefs.h.patch \ |
| " |
| SRC_URI[sha256sum] = "abbf9c8c3df4d5233d5888c6cfa85c1bb68a6923749bd4dd1abc6e1e93986f17" |
| |
| RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \ |
| ${PYTHON_PN}-setuptools \ |
| ${PYTHON_PN}-six \ |
| " |
| |
| inherit setuptools3 |
| inherit pypi |
| |
| export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1" |
| |
| BORING_SSL_PLATFORM_arm = "linux-arm" |
| BORING_SSL_PLATFORM_x86-64 = "linux-x86_64" |
| BORING_SSL_PLATFORM ?= "unsupported" |
| export GRPC_BORING_SSL_PLATFORM = "${BORING_SSL_PLATFORM}" |
| |
| BORING_SSL_x86-64 = "1" |
| BORING_SSL_arm = "1" |
| BORING_SSL ?= "0" |
| export GRPC_BUILD_WITH_BORING_SSL_ASM = "${BORING_SSL}" |
| |
| GRPC_CFLAGS_append_toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions" |
| export GRPC_PYTHON_CFLAGS = "${GRPC_CFLAGS}" |
| |
| CLEANBROKEN = "1" |
| |
| BBCLASSEXTEND = "native nativesdk" |
| |
| CCACHE_DISABLE = "1" |
| |
| # needs vdso support |
| COMPATIBLE_HOST_libc-musl_powerpc64le = "null" |