blob: 43d2c058a3801ea408bd8905df1aa997a94b7f5d [file] [log] [blame]
SUMMARY = "OpenBMC NCPLite Check Inventory State Service"
DESCRIPTION = "OpenBMC NCPLite Check Inventory State Daemon."
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
inherit systemd
DEPENDS += "systemd"
RDEPENDS:${PN} += "bash"
SRC_URI = " file://inventory-log.sh \
file://inventory-log.service \
"
do_install() {
install -d ${D}${libexecdir}/${BPN}
install -m 0755 ${WORKDIR}/inventory-log.sh ${D}${libexecdir}/${BPN}
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/inventory-log.service ${D}${systemd_system_unitdir}
}
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE:${PN} = "inventory-log.service"