blob: 8c34677bc01cc54cfcb647cc3a540115818b0df6 [file] [log] [blame]
SUMMARY = "Phosphor DBUS Object Manager"
DESCRIPTION = "Phosphor DBUS object manager."
HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
inherit autotools pkgconfig
inherit obmc-phosphor-python-autotools
inherit obmc-phosphor-dbus-service
inherit obmc-phosphor-systemd
DEPENDS += "systemd"
DEPENDS += "autoconf-archive-native"
DBUS_SERVICE_${PN} += "xyz.openbmc_project.ObjectMapper.service"
SYSTEMD_SERVICE_${PN} = "mapper-wait@.service mapper-wait-until-removed@.service"
RDEPENDS_libmapper += "libsystemd"
RDEPENDS_${PN} += " \
python-xml \
python-dbus \
python-pygobject \
pyphosphor-dbus \
"
SRC_URI += "git://github.com/openbmc/phosphor-objmgr"
SRCREV = "c7a7c45fec58ff593aecce92699b9ee41823d48e"
S = "${WORKDIR}/git"
python populate_packages_prepend () {
mapperlibdir = d.getVar("libdir", True)
do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True)
}
PACKAGES_DYNAMIC += "^libmapper.*"
FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"