blob: 623d7d26d8dda6cbcbda1361eee5f111449e0a21 [file] [log] [blame]
SUMMARY = "Phosphor OpenBMC OEM Commands for OpenPOWER systems"
DESCRIPTION = "Phosphor OpenBMC IPMI OEM commands for OpenPOWER based systems"
HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
PR = "r1"
RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw"
inherit obmc-phosphor-license
DEPENDS += "systemd \
host-ipmid \
"
RDEPENDS_${PN} += "libsystemd"
SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
SRCREV = "f79a21f3c1e5209f3c911399c3b822ae93bb973d"
FILES_${PN} += "${libdir}/host-ipmid/*.so"
FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug"
S = "${WORKDIR}/git"
do_install() {
install -m 0755 -d ${D}${libdir}/host-ipmid
install -m 0755 ${S}/*.so ${D}${libdir}/host-ipmid/
}