blob: 0377994de1da56fdd3ca3cb29569dbd703a3b445 [file] [log] [blame]
SUMMARY = "MCTP stack"
DESCRIPTION = "MCTP library implementing the MCTP base specification"
PR = "r1"
PV = "1.0+git${SRCPV}"
inherit systemd
inherit autotools pkgconfig
HOMEPAGE = "https://github.com/openbmc/libmctp"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=0d30807bb7a4f16d36e96b78f9ed8fae"
SRC_URI = "git://github.com/openbmc/libmctp \
file://default"
SRCREV = "d4103f8f55e1f20869809b61be2567c48c817bb2"
CONFFILES_${PN} = "${sysconfdir}/default/mctp"
DEPENDS += "autoconf-archive-native \
systemd \
"
SYSTEMD_SERVICE_${PN} = "mctp-demux.service"
do_install_append() {
install -d ${D}${sysconfdir}/default
install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/mctp
}
S = "${WORKDIR}/git"