blob: aee8dd38c129df5c4eae9439e43198eddae2966b [file] [log] [blame]
SUMMARY = "Network DBUS object"
DESCRIPTION = "Network DBUS object"
HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
PR = "r1"
inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
inherit obmc-phosphor-sdbus-service
SYSTEMD_SERVICE_${PN} += "network.service network-update-dns.service"
RDEPENDS_${PN} += "python-dbus python-pygobject python-ipy"
SRC_URI += "git://github.com/openbmc/phosphor-networkd"
SRCREV = "15d498e2568b6e104de75e7423caab0c9a487485"
S = "${WORKDIR}/git"
do_install() {
install -d ${D}/${sbindir}
install ${S}/netman.py ${D}/${sbindir}
install ${S}/netman_watch_dns ${D}/${sbindir}
}