meta-ampere: mtmitchell: led: support bmc_booted leds

This commit adds bmc_ready and sw_heartbeat leds to bmc_booted group.
When BMC's status is Ready, phosphor-led-manager shall assert bmc_ready
GPIO and create bmc/sw heart-beat signals to CPLD/HOST.

By the heartbeat signals are create by leds, the service to create
heartbeat signals is redundant, therefore ampere-bmc-heartbeat.service
shall be removed.

Tested:
   1. Turn on/off, power cycle, reboot host features work correctly.

Signed-off-by: Thang Tran <thuutran@amperecomputing.com>
Change-Id: If21649c1a70a6b43acf8130561181e534f762b61
diff --git a/meta-ampere/meta-mitchell/recipes-ampere/platform/ampere-platform-init.bb b/meta-ampere/meta-mitchell/recipes-ampere/platform/ampere-platform-init.bb
index 3a1eb2c..d79548a 100644
--- a/meta-ampere/meta-mitchell/recipes-ampere/platform/ampere-platform-init.bb
+++ b/meta-ampere/meta-mitchell/recipes-ampere/platform/ampere-platform-init.bb
@@ -14,20 +14,17 @@
 
 SRC_URI = " \
            file://ampere-platform-init.service \
-           file://ampere-bmc-heartbeat.service \
            file://ampere_platform_init.sh \
-           file://ampere_bmc_heartbeat.sh \
            file://mtmitchell_platform_gpios_init.sh \
            file://gpio-lib.sh \
           "
 SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = "ampere-platform-init.service ampere-bmc-heartbeat.service"
+SYSTEMD_SERVICE:${PN} = "ampere-platform-init.service"
 
 do_install () {
     install -d ${D}${sbindir}
     install -m 0755 ${WORKDIR}/gpio-lib.sh ${D}${sbindir}/
     install -m 0755 ${WORKDIR}/ampere_platform_init.sh ${D}${sbindir}/
-    install -m 0755 ${WORKDIR}/ampere_bmc_heartbeat.sh ${D}${sbindir}/
     install -m 0755 ${WORKDIR}/mtmitchell_platform_gpios_init.sh ${D}${sbindir}/platform_gpios_init.sh
     install -d ${D}${systemd_unitdir}/system/
     install -m 0644 ${WORKDIR}/ampere-platform-init.service ${D}${systemd_unitdir}/system