blob: 38f6eb6ebcab383002a27bbb5182c21db96ae9ea [file] [log] [blame]
SUMMARY = "Backup, restore, import, and export panel layouts"
SECTION = "x11/application"
LICENSE = "GPL-3.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
inherit python3native gettext gtk-icon-cache features_check
REQUIRED_DISTRO_FEATURES = "x11 gobject-introspection-data"
DEPENDS += "intltool-native"
SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/1.0/${BP}.tar.bz2"
SRC_URI[sha256sum] = "6d08354e8c44d4b0370150809c1ed601d09c8b488b68986477260609a78be3f9"
do_configure() {
# special configure - no autotools...
./configure --prefix=${prefix}
}
do_install() {
oe_runmake 'DESTDIR=${D}' install
sed -i 's:${PYTHON}:python3:g' ${D}${bindir}/xfce4-panel-profiles
}
FILES:${PN} += "${datadir}/metainfo"
RDEPENDS:${PN} += "python3-pygobject python3-pexpect"