blob: cdcae48d6003374cf4c33e9ea5ceb69dd85c7004 [file] [log] [blame]
SUMMARY = "Simple Python wrapper around the OpenSSL library"
HOMEPAGE = "https://pyopenssl.org/"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
DEPENDS += "openssl ${PYTHON_PN}-cryptography"
SRC_URI[sha256sum] = "6b2cba5cc46e822750ec3e5a81ee12819850b11303630d575e98108a079c2b12"
PYPI_PACKAGE = "pyOpenSSL"
inherit pypi setuptools3
PACKAGES =+ "${PN}-tests"
FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
RDEPENDS:${PN}:class-target = " \
${PYTHON_PN}-cryptography \
${PYTHON_PN}-six \
${PYTHON_PN}-threading \
"
RDEPENDS:${PN}-tests = "${PN}"
BBCLASSEXTEND = "native nativesdk"