blob: 831ddf0cab1da2dee9035ebc10144965f76a0a7c [file] [log] [blame]
SUMMARY = "NetworkManager"
SECTION = "net/misc"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=cbbffd568227ada506640fe950a4823b \
file://libnm-util/COPYING;md5=1c4fa765d6eb3cd2fbd84344a1b816cd \
file://docs/api/html/license.html;md5=51d7fb67bde992e58533a8481cee070b \
"
DEPENDS = "libnl dbus dbus-glib libgudev util-linux libndp libnewt polkit"
inherit gnomebase gettext systemd bluetooth bash-completion vala gobject-introspection
SRC_URI = " \
${GNOME_MIRROR}/NetworkManager/${@gnome_verdir("${PV}")}/NetworkManager-${PV}.tar.xz \
file://0001-don-t-try-to-run-sbin-dhclient-to-get-the-version-nu.patch \
file://0002-add-pkg-config-for-libgcrypt.patch \
file://0003-core-fix-failure-to-configure-routes-due-to-wrong-de.patch \
file://0004-ppp-manager-clear-ppp_watch_id-upon-pppd-termination.patch \
file://0005-device-update-ip_iface-only-if-IP-interface-exists.patch \
file://0006-Fix-nm-version-macro-includes.patch \
"
SRC_URI[md5sum] = "a8f54460a4708efd840358f32d0968fd"
SRC_URI[sha256sum] = "1bcfce8441dfd9f432a100d06b54f3831a2275cccc3b74b1b4c09a011e179fbc"
S = "${WORKDIR}/NetworkManager-${PV}"
EXTRA_OECONF = " \
--disable-ifcfg-rh \
--disable-ifnet \
--disable-ifcfg-suse \
--disable-more-warnings \
--with-iptables=${sbindir}/iptables \
--with-tests \
--with-nmtui=yes \
"
do_compile_prepend() {
export GIR_EXTRA_LIBS_PATH="${B}/libnm-util/.libs"
}
PACKAGECONFIG ??= "nss ifupdown netconfig dhclient dnsmasq \
${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','consolekit',d)} \
${@bb.utils.contains('DISTRO_FEATURES','bluetooth','${BLUEZ}','',d)} \
${@bb.utils.contains('DISTRO_FEATURES','wifi','wifi','',d)} \
"
PACKAGECONFIG[systemd] = " \
--with-systemdsystemunitdir=${systemd_unitdir}/system --with-session-tracking=systemd --enable-polkit, \
--without-systemdsystemunitdir, \
polkit \
"
PACKAGECONFIG[bluez5] = "--enable-bluez5-dun,--disable-bluez5-dun,bluez5"
# consolekit is not picked by shlibs, so add it to RDEPENDS too
PACKAGECONFIG[consolekit] = "--with-session-tracking=consolekit,,consolekit,consolekit"
PACKAGECONFIG[concheck] = "--with-libsoup=yes,--with-libsoup=no,libsoup-2.4"
PACKAGECONFIG[modemmanager] = "--with-modem-manager-1=yes,--with-modem-manager-1=no,modemmanager"
PACKAGECONFIG[ppp] = "--enable-ppp,--disable-ppp,ppp,ppp"
# Use full featured dhcp client instead of internal one
PACKAGECONFIG[dhclient] = "--with-dhclient=${base_sbindir}/dhclient,,,dhcp-client"
PACKAGECONFIG[dnsmasq] = "--with-dnsmasq=${bindir}/dnsmasq"
PACKAGECONFIG[nss] = "--with-crypto=nss,,nss"
PACKAGECONFIG[gnutls] = "--with-crypto=gnutls,,gnutls libgcrypt"
PACKAGECONFIG[wifi] = "--enable-wifi=yes,--enable-wifi=no,wireless-tools,wpa-supplicant wireless-tools"
PACKAGECONFIG[ifupdown] = "--enable-ifupdown,--disable-ifupdown"
PACKAGECONFIG[netconfig] = "--with-netconfig=yes,--with-netconfig=no"
PACKAGECONFIG[qt4-x11-free] = "--enable-qt,--disable-qt,qt4-x11-free"
PACKAGES =+ "libnmutil libnmglib libnmglib-vpn ${PN}-tests \
${PN}-nmtui ${PN}-nmtui-doc \
${PN}-adsl \
"
FILES_libnmutil += "${libdir}/libnm-util.so.*"
FILES_libnmglib += "${libdir}/libnm-glib.so.*"
FILES_libnmglib-vpn += "${libdir}/libnm-glib-vpn.so.*"
FILES_${PN}-adsl = "${libdir}/NetworkManager/libnm-device-plugin-adsl.so"
FILES_${PN} += " \
${libexecdir} \
${libdir}/pppd/*/nm-pppd-plugin.so \
${libdir}/NetworkManager/*.so \
${datadir}/polkit-1 \
${datadir}/dbus-1 \
${base_libdir}/udev/* \
${systemd_unitdir}/system \
"
RRECOMMENDS_${PN} += "iptables \
${@bb.utils.contains('PACKAGECONFIG','dnsmasq','dnsmasq','',d)} \
"
RCONFLICTS_${PN} = "connman"
FILES_${PN}-dbg += " \
${libdir}/NetworkManager/.debug/ \
${libdir}/pppd/*/.debug/ \
"
FILES_${PN}-dev += " \
${datadir}/NetworkManager/gdb-cmd \
${libdir}/pppd/*/*.la \
${libdir}/NetworkManager/*.la \
"
FILES_${PN}-tests = " \
${bindir}/nm-online \
"
FILES_${PN}-nmtui = " \
${bindir}/nmtui \
${bindir}/nmtui-edit \
${bindir}/nmtui-connect \
${bindir}/nmtui-hostname \
"
FILES_${PN}-nmtui-doc = " \
${mandir}/man1/nmtui* \
"
SYSTEMD_SERVICE_${PN} = "NetworkManager.service NetworkManager-dispatcher.service"
do_install_append() {
rm -rf ${D}/run ${D}${localstatedir}/run
}