blob: 668bde568f033c46326a1633dc09588f71d5ef51 [file] [log] [blame]
DESCRIPTION = "Trusted Services ts-demo deployment for arm-linux. \
Used for running simple TS demo from Linux user-space \
on an Arm platform with real deployments of trusted services."
TS_ENV = "arm-linux"
require trusted-services.inc
DEPENDS += "python3-jsonschema-native python3-jinja2-native"
DEPENDS += "libts"
RDEPENDS:${PN} += "libts"
OECMAKE_SOURCEPATH="${S}/deployments/ts-demo/${TS_ENV}"
# Mbedtls 3.1.0 does not compile with clang.
# This can be removed after TS updated required mbedtls version
TOOLCHAIN = "gcc"
FILES:${PN} = "${bindir}/ts-demo"
do_install:append () {
install -d ${D}${bindir}
mv ${D}${TS_INSTALL}/bin/ts-demo ${D}${bindir}
rm -r --one-file-system ${D}${TS_INSTALL}
}