blob: 7af45828612175a4bcbfa82acc16332a68a863f3 [file] [log] [blame]
SUMMARY = "Python documentation generator"
HOMEPAGE = "http://sphinx-doc.org/"
SECTION = "devel/python"
LICENSE = "BSD-2-Clause & MIT & BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb6ac1b115a1ed24a12d9f15b633993"
PYPI_PACKAGE = "Sphinx"
SRC_URI[sha256sum] = "61e025f788c5977d9412587e733733a289e2b9fdc2fef8868ddfbfc4ccfe881d"
inherit python_flit_core pypi
do_install:append () {
# The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
}
RDEPENDS:${PN} = "\
python3-alabaster \
python3-babel \
python3-docutils \
python3-imagesize \
python3-jinja2 \
python3-packaging \
python3-pygments \
python3-requests \
python3-snowballstemmer \
python3-sphinxcontrib-applehelp \
python3-sphinxcontrib-devhelp \
python3-sphinxcontrib-htmlhelp \
python3-sphinxcontrib-jsmath \
python3-sphinxcontrib-qthelp \
python3-sphinxcontrib-serializinghtml \
"
BBCLASSEXTEND = "native nativesdk"