blob: df3e2750f4dc1763ae27d8ad68d3beac91835cc2 [file] [log] [blame]
SUMMARY = "Temp placeholder for skeleton function"
DESCRIPTION = "Temp placeholder for skeleton repository"
HOMEPAGE = "http://github.com/openbmc/skeleton"
PR = "r1"
inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
inherit obmc-phosphor-chassis-mgmt
inherit obmc-phosphor-fan-mgmt
inherit obmc-phosphor-flash-mgmt
inherit obmc-phosphor-policy-mgmt
inherit obmc-phosphor-sensor-mgmt
inherit obmc-phosphor-system-mgmt
DEPENDS += "glib-2.0"
RDEPENDS_${PN} += "python-subprocess python-tftpy"
SRC_URI += "git://github.com/openbmc/skeleton"
SRCREV = "1355e032d2becbc5afa165af23e3d6aec2146c5e"
S = "${WORKDIR}"
do_compile() {
oe_runmake -C git
}
do_install() {
source=${S}/git
install -d ${D}/${sbindir} ${D}${libdir}
for i in ${source}/bin/*; do
install $i ${D}/${sbindir}
done
for i in ${source}/lib/*; do
install $i ${D}/${libdir}
done
}