blob: 3545018b3a0f03058076bb218ba4df317640dbef [file] [log] [blame]
SUMMARY = "Open POWER DBus Interfaces"
DESCRIPTION = "Generated bindings, using sdbus++, for the openpower YAML"
PR = "r1"
PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
inherit python3native
inherit phosphor-dbus-yaml
DEPENDS += "autoconf-archive-native"
DEPENDS += "${PYTHON_PN}-sdbus++-native"
DEPENDS += "phosphor-dbus-interfaces"
SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces"
SRCREV = "109ded04f3fec7bbbd93f9c9956a355f4894a51f"
PACKAGECONFIG ??= "libopenpower_dbus"
PACKAGECONFIG[libopenpower_dbus] = " \
--enable-libopenpower_dbus, \
--disable-libopenpower_dbus, \
systemd sdbusplus, \
libsystemd \
"
PACKAGECONFIG_remove_class-native = "libopenpower_dbus"
PACKAGECONFIG_remove_class-nativesdk = "libopenpower_dbus"
BBCLASSEXTEND += "native nativesdk"